30
2021
11

通达信“加仓减仓主图”指标公式和选股公式——指标分享​,胜率48.26%

QQ截图20211126084024.png

上一篇《通达信“主升波段”指标公式和选股公式——指标分享,胜率48.34%


公式如下 :

MA05:MA(C,5)LINETHICK3,COLOR00CCFF;

MA10:=MA(C,10);

MA20:=MA(C,20);

MA30:=MA(C,30);

五日乖离率:=(C-MA05)/MA05*100;

BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;

速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);

加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;

IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORRED;

BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORGREEN;

DRAWTEXT_FIX(C>O,0.01,0.9,0,'微信公众号:水鸭的投资日记'),COLORRED;

三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;

VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);

VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);

BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;

强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);

加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)

AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;

清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);

DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;

JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;

减仓:=FILTER(JC,10);

MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;

买入:=FILTER(MR,10);

DRAWTEXT(减仓,HIGH*1.02,'←风险'),COLORCYAN;

DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;

DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;

DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;

VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));

VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);

MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;

压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;

支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;


信号很多,就做一个“买入”的选股吧,如果有其他选股公式需要的,扫描右上角二维码联系我。

选股公式如下 :

MA05:=MA(C,5);

MA10:=MA(C,10);

MA20:=MA(C,20);

MA30:=MA(C,30);

五日乖离率:=(C-MA05)/MA05*100;

三拾日乖离率:=(C-MA30)/MA30*100;

MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;

FILTER(MR,10);


测试一下,平仓规则是,不论盈亏,以持股5天后平仓为条件

QQ截图20211126084409.png

胜率48.26%


QQ截图20211130082557.png

另一个选股公式,将在今晚微信公众号上分享,敬请留意。


下一篇《通达信“云端操盘主图”指标公式和选股公式——指标分享,胜率48.60%



打赏
« 上一篇 下一篇 »

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。