30
2021
11

通达信“云端操盘主图”指标公式和选股公式——指标分享​,胜率48.60%

QQ截图20211126082818.png

上一篇《通达信“加仓减仓主图”指标公式和选股公式——指标分享,胜率48.26%


公式如下 :

W1:=FILTER(O<REF(L,1) && C>O && VOL>REF(V,1),13);

JH:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;

SZ:=FILTER(CROSS(JH,35),13);

SX:=FILTER(CROSS(JH,30),7);

SQ:=FILTER(CROSS(71,JH),74);

SD:=FILTER(CROSS(80,JH),74);

BB:=IF(CAPITAL<1,SQ,SD);

AA:=IF(CAPITAL<1,SZ,SX);

CC:=REF(HHV(CLOSE,120),1);

DD:=REF(LLV(CLOSE,120),1);

WW:=((100*(CLOSE-DD))/(CC-DD));

FF:=(EMA(AMOUNT,5)/REF(EMA(AMOUNT,5),5));

BZ:=FILTER(((FF>=2 && WW<35 && BARSCOUNT(C)>30) OR (FF>=2 && WW<100 && BARSCOUNT(C)<50)),30);

STICKLINE(C>O OR C>REF(C,1),H,L,0,0),COLOR0022FF;

STICKLINE(C>O OR C>REF(C,1),C,O,3.2,0),COLOR002288;

STICKLINE(C>O OR C>REF(C,1),C,O,2.6,0),COLOR0033AA;

STICKLINE(C>O OR C>REF(C,1),C,O,1.9,0),COLOR0044CC;

STICKLINE(C>O OR C>REF(C,1),C,O,1.1,0),COLOR0055EE;

STICKLINE(C>O OR C>REF(C,1),C,O,0.3,0),COLOR0088FF;

STICKLINE(C<O OR C<REF(C,1),H,L,0,1),COLORFF8800;

STICKLINE(C<O OR C<REF(C,1),C,O,3.2,0),COLORFF2200;

STICKLINE(C<O OR C<REF(C,1),C,O,2.6,0),COLORFF4400;

STICKLINE(C<O OR C<REF(C,1),C,O,1.9,0),COLORFF6600;

STICKLINE(C<O OR C<REF(C,1),C,O,1.1,0),COLORFF8800;

STICKLINE(C<O OR C<REF(C,1),C,O,0.3,0),COLORFFAA00;

STICKLINE(C=REF(C,1),H,L,0,1),COLORFFFFFF;

STICKLINE(C=REF(C,1),C,O,3.2,0),COLOR555555;

STICKLINE(C=REF(C,1),C,O,2.6,0),COLOR777777;

STICKLINE(C=REF(C,1),C,O,1.9,0),COLOR999999;

STICKLINE(C=REF(C,1),C,O,1.1,0),COLORCCCCCC;

{STICKLINE(C=REF(C,1),C,O,0.3,0),COLORDDDDDD;}

STICKLINE(W1,H,L,0,1),COLORFF55FF;

STICKLINE(W1,C,O,3.2,0),COLOR880088;

STICKLINE(W1,C,O,2.6,0),COLORAA00AA;

STICKLINE(W1,C,O,1.9,0),COLORCC00CC;

STICKLINE(W1,C,O,1.1,0),COLOREE00EE;

STICKLINE(W1,C,O,0.3,0),COLORFF44FF;

STICKLINE(AA,H,L,0,1),COLORYELLOW;

STICKLINE(AA,C,O,3.2,0),COLOR117777;

STICKLINE(AA,C,O,2.6,0),COLOR119999;

STICKLINE(AA,C,O,1.9,0),COLOR11BBBB;

STICKLINE(AA,C,O,1.1,0),COLOR11DDDD;

STICKLINE(AA,C,O,0.3,0),COLOR44FFFF;

STICKLINE(BB,H,L,0,1),COLORGREEN;

STICKLINE(BB,C,O,3.2,0),COLOR006600;

STICKLINE(BB,C,O,2.6,0),COLOR008800;

STICKLINE(BB,C,O,1.9,0),COLOR00AA00;

STICKLINE(BB,C,O,1.1,0),COLOR00CC00;

STICKLINE(BB,C,O,0.3,0),COLOR00FF00;

STICKLINE(BZ,H,L,0,1),COLOR0000FF;

STICKLINE(BZ,C,O,3.2,0),COLOR000066;

STICKLINE(BZ,C,O,2.6,0),COLOR000088;

STICKLINE(BZ,C,O,1.9,0),COLOR0000AA;

STICKLINE(BZ,C,O,1.1,0),COLOR0000CC;

STICKLINE(BZ,C,O,0.3,0),COLOR2200FF;

VAR1AA:=((2)*(CLOSE)+OPEN+HIGH+LOW)/(5);

VAR2AA:=VOL;

上升价格线: (SUM((VAR1AA)*(VAR2AA),8))/(SUM(VAR2AA,8)),COLORRED;

下降价格线:LLV(上升价格线,8),COLOR007700;

VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);

DRAWTEXT(FILTER((VAR4AA>90),34),(LOW)*(0.99),'*加仓'),COLORRED;

A1AA:=9;

A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);

DRAWTEXT_FIX(C>O,0.01,0.9,0,'微信公众号:水鸭的投资日记'),COLORRED;

DRAWTEXT(FILTER((A2AA>0),34),(HIGH)*(1.01),'*警'),COLORGREEN;

VAR1:=REF(CLOSE,1);

VAR2:=MA(CLOSE,5);

VAR3:=SMA(MAX(CLOSE-VAR1,0),6,1)/SMA(ABS(CLOSE-VAR1),6,1)*100;

VAR4:=SMA(MAX(CLOSE-VAR1,0),12,1)/SMA(ABS(CLOSE-VAR1),12,1)*100;

VAR5:=SMA(MAX(CLOSE-VAR1,0),24,1)/SMA(ABS(CLOSE-VAR1),24,1)*100;

VAR6:=IF(CROSS(VAR3,VAR5),LOW,REF(LOW,BARSLAST(CROSS(VAR3,VAR5))));

VAR7:=IF(CROSS(VAR5,VAR3),HIGH,REF(HIGH,BARSLAST(CROSS(VAR5,VAR3))));

VAR8:=IF(CLOSE>=MA(CLOSE,20),80,50);

VAR9:=IF(CLOSE>=MA(CLOSE,20),50,20);

VARA:=IF(VAR3<VAR8 AND REF(VAR3,1)>=VAR8,HHV(REF(HIGH,1),BARSLAST(VAR3>=VAR8 AND REF(VAR3,1)<VAR8)-1),REF(HHV(REF(HIGH,1),BARSLAST(VAR3>=VAR8 AND REF(VAR3,1)<VAR8)-1),BARSLAST(VAR3<VAR8 AND REF(VAR3,1))));

VARB:=IF(HIGH>VARA,LOW,REF(LOW,BARSLAST(HIGH>VARA)));

VARC:=IF(HIGH>VARA,VAR3,REF(VAR3,BARSLAST(HIGH>VARA)));

VARD:=IF(HIGH>VARB AND VAR3<VARC AND VAR3<VAR5,HIGH,REF(HIGH,BARSLAST(HIGH>VARB AND VAR3<VARC AND VAR3<VAR5)));

VARE:=IF(VAR3>VAR9 AND REF(VAR3,1)<=VAR9,LLV(REF(LOW,1),BARSLAST(VAR3<=VAR9 AND REF(VAR3,1)>VAR9)-1),REF(LLV(REF(LOW,1),BARSLAST(VAR3<=VAR9 AND REF(VAR3,1)>VAR9)-1),BARSLAST(VAR3>VAR9 AND REF(VAR3,1))));

VARF:=IF(LOW<VARE,HIGH,REF(HIGH,BARSLAST(LOW<VARE)));

VAR10:=IF(LOW<VARE,VAR3,REF(VAR3,BARSLAST(LOW<VARE)));

VAR11:=IF(LOW<VARF AND VAR3>VAR10 AND VAR3>VAR5,LOW,REF(LOW,BARSLAST(LOW<VARF AND VAR3>VAR10 AND VAR3>VAR5)));

支撑线:VAR11,COLORYELLOW,LINETHICK1;

压力线:VARD, COLORGREEN,LINETHICK1;


信号很多,就做一个“加仓”的选股吧,如果有其他选股公式需要的,扫描右上角二维码联系我。

选股公式如下 :

AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

AB:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (AA>0),91,0);

FILTER((AB>90),34);


测试一下,平仓规则是,不论盈亏,以持股5天后平仓为条件

QQ截图20211126083224.png

胜率48.60%


下一篇《通达信“云端建仓”指标公式和选股公式——指标分享,胜率50.15%




打赏
« 上一篇 下一篇 »

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。