09
2021
11

通达信“短线起涨点主图”指标公式和选股公式——指标分享​,胜率47.81%

QQ截图20211105083036.png

上一篇《通达信“太极红量”指标公式和选股公式——指标分享,胜率46.50%


公式如下 :

M20:MA(CLOSE,20),COLORWHITE;

M60:MA(CLOSE,60),COLORLIBLUE;

MA144:=MA(CLOSE,144);

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

A1:=BARSLAST(REF(CROSS(DEA,DIFF),1));

A2:=BARSLAST(REF(CROSS(DIFF,DEA),1));

VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

HONGJU:=IF(VAR1>0,VAR1,0);

GAOPAO:=CROSS(DIFF,DEA) AND HONGJU>=40;

DRAWICON(GAOPAO,HIGH*1.01,6);

DRAWTEXT(GAOPAO,HIGH*1.02,'顶背'),COLORGREEN;

LLVV:=LLV(LOW,5);

DIXI:=CROSS(DEA,DIFF) AND REF(DEA,A1+1)>0 AND DEA<0;

DRAWICON(DIXI,LOW*0.96,38);

DRAWTEXT(DIXI,LOW*0.96,'波段低吸'),COLORYELLOW;

工作线:EMA(CLOSE,17),COLORYELLOW;

生命线:MA(CLOSE,56),COLORRED;

M0:=MA(CLOSE,5);

M10:=MA(CLOSE,12);

M1:=MA(CLOSE,20);

M30:=MA(CLOSE,30);

M2:=MA(CLOSE,60);

M3:=MA(CLOSE,240);

M4:=MA(CLOSE,120);

M41:=MA(CLOSE,41);

TJ2:=MA(CLOSE,3)<M2;

VAR2:=(CLOSE*2+HIGH+LOW)/4;

SK:=EMA(VAR2,13)-EMA(VAR2,73);

SD:=EMA(SK,2);

短线:=CROSS(SK,SD) AND SK<0.05 AND (VOL/MA(VOL,5)>2 OR CLOSE/REF(CLOSE,1)>0.035 AND CLOSE>EMA(CLOSE,17));

STICKLINE(短线,HIGH,LOW,0.5,0),COLORFFFF00;

STICKLINE(短线,OPEN,CLOSE,10,1),LINETHICK2,COLORFFFF00;

CY:=BARSLAST(短线);

MACD双底:=REF(LOW,A2+1)<CLOSE AND CROSS(DIFF,DEA);

介入:=COUNT(短线,4)=1 AND COUNT(MACD双底,1)=1 AND CLOSE/MA(CLOSE,56)*1000>980 AND CLOSE>OPEN AND VOL>=MA(VOL,5) AND DIFF>=-0.1;

DRAWTEXT(介入,LOW*0.96,'起涨点'),COLORRED;

DRAWICON(介入,LOW*0.96,1);

DRAWTEXT_FIX(C>O,0.01,0.9,0,'微信公众号:水鸭的投资日记'),COLORRED;

反向顶背:=REF(CLOSE,A2+1)>CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

逃顶:=CROSS(SD,SK) AND SK>0.2 AND VOL/MA(VOL,5)<2;

逃顶成立:=COUNT(逃顶,4)=1 AND COUNT(反向顶背,1)=1;

DRAWICON(逃顶成立,HIGH*1.01,15);

DRAWTEXT(逃顶成立,HIGH*1.01,'逃顶'),COLORGREEN;

N1G:=CLOSE/REF(CLOSE,1)>=1.097 AND HIGH=CLOSE AND NOT(OPEN=HIGH);

A1G:=BARSLAST(N1G);

A2G:=LLV(LOW,A1G-1)>REF(LOW,A1G) AND CLOSE/REF(OPEN,A1G)>1 AND CLOSE/REF(OPEN,A1G)<=1.04;

XGGG:=FILTER(A2G,3) AND A1G>=4 AND A1G<=20;

DRAWICON(XGGG,LOW*0.96,41);

DRAWTEXT(XGGG,LOW*0.96,'注意'),COLORYELLOW;

MA20:=MA(CLOSE,20);

XPP1:=CROSS(DEA,DIFF) AND CLOSE>MA20 AND MA20>REF(MA20,1) AND DIFF>REF(DIFF,A2+1);

DRAWICON(XPP1,LOW*0.96,3);

DRAWTEXT(XPP1,LOW*0.96,'暂出'),COLORWHITE;

XPP2:=XPP1 AND A1G>=4 AND A1G<=20;

DRAWICON(XPP2,LOW*0.98,17);


信号很多,就做一个“波段低吸”的选股吧,如果有其他选股公式需要的,扫描右上角二维码联系我。

选股公式如下 :

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

A1:=BARSLAST(REF(CROSS(DEA,DIFF),1));

CROSS(DEA,DIFF) AND REF(DEA,A1+1)>0 AND DEA<0;


测试一下,平仓规则是,不论盈亏,以持股5天后平仓为条件

QQ截图20211105083443.png

胜率47.81%


QQ截图20211109082650.png

另一个选股公式,将在今晚微信公众号上分享,敬请留意。


下一篇《通达信“又一抄底”指标公式和选股公式——指标分享,胜率50.73%



打赏
« 上一篇 下一篇 »

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。