27
2021
10

通达信“庄买卖+MACD”指标公式和选股公式——指标分享​,胜率47.78%

QQ截图20211025085500.png

上一篇《通达信“吹响集结号主图”指标公式和选股公式——指标分享,胜率47.22%


公式如下 :

P:=13;S:=5;M:=1;

DIFF:EMA(C,S)-EMA(C,P);

DEA:EMA(DIFF,M),COLORRED;

MACD:2*(DIFF-DEA),COLORSTICK;

P1:=P;S1:=S;

DIFF1:EMA(C,S1)-EMA(C,P1);

DEA1:EMA(DIFF,M),COLORRED;

MACD1:=2*(DIFF1-DEA1),COLORSTICK;

MACD2:=DEA;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2>0,0,MACD2*50,3,0 ),COLOR00AAFF;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2>0,0,MACD2*50,1.8,0 ),COLOR00BBFF;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2>0,0,MACD2*50,1.3,0 ),COLOR00CCFF;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2>0,0,MACD2*50,1.2,0 ),COLOR00DDFF;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2>0,0,MACD2*50,1,0 ),COLOR00EEFF;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2>0,0,MACD2*50,0.5,0 ),COLOR00FFFF;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2>0,0,MACD2*50,3.4,0 ),COLOR0000AA;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2>0,0,MACD2*50,3.2,0),COLOR0011BB;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2>0,0,MACD2*50,3,0),COLOR0022CC;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2>0,0,MACD2*50,2,0),COLOR0033DD;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2>0,0,MACD2*50,1,0),COLOR0044EE;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2>0,0,MACD2*50,0.5,0),COLOR0055FF;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2<=0,0,MACD2*50,3.4,0),COLORAA00BB;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2<=0,0,MACD2*50,3.2,0),COLORBB11BB;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2<=0,0,MACD2*50,3,0),COLORCC22BB;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2<=0,0,MACD2*50,2,0 ),COLORDD33BB;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2<=0,0,MACD2*50,1,0),COLOREE44BB;

STICKLINE(MACD2>REF(MACD2,1)AND MACD2<=0,0,MACD2*50,0.5,0 ),COLORFF55BB;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2<=0,0,MACD2*50,3,0 ),COLORFF7700;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2<=0,0,MACD2*50,1.5 ,0 ),COLORFF8811;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2<=0,0,MACD2*50,1.2,0 ),COLORFFAA22;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2<=0,0,MACD2*50,1.0 ,0 ),COLORFFBB33;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2<=0,0,MACD2*50,0.8 ,0 ),COLORFFDD44;

STICKLINE(MACD2<=REF(MACD2,1)AND MACD2<=0,0,MACD2*50,0.5 ,0 ),COLORFFFF55;

VARA:=REF(LOW,1);

VARB:=SMA(ABS(LOW-VARA),3,1)/SMA(MAX(LOW-VARA,0),3,1)*100;

VARC:=EMA(IF(CLOSE*1.3,VARB*10,VARB/10),3);

VARD:=LLV(LOW,30);

VARE:=HHV(VARC,30);

VARF:=IF(MA(CLOSE,58),1,0);

VARG:=EMA(IF(LOW<=VARD,(VARC+VARE*2)/2,0),3)/618*VARF;

VARH:=IF(VARG>28,28,VARG);

吸筹:STICKLINE(VARH>-120,0,VARH,6,1),COLOR0FFFFF;

备钱:IF(吸筹,1,0),COLOR0FFFFF;

DRAWTEXT_FIX(C>O,0.01,0.9,0,'微信公众号:水鸭的投资日记'),COLORRED;

RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

X:=LLV(J,2)=LLV(J,8);

买入时机: IF(CROSS(J,3),65,0),COLORFF00FF,LINETHICK3;

DRAWTEXT(买入时机,70.1,' 跟庄'),COLOR00FF00;

VA:=(2*C+H+L)/4;

VB:=LLV(L,5);

VC:=HHV(H,5);

红线上穿买:EMA((VA-VB)/(VC-VB)*100,5),COLORRED;

红线下穿卖:EMA(红线上穿买,3),COLORFFFF00;

趋势:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),COLOR00FFFF;

秘密买点: IF(趋势<=3,20,0),COLOR00FF00,LINETHICK3;

机构建仓: IF(趋势<5,40,0),COLORFFFFFF,LINETHICK3;

N:=5;

VAR1:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-

3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;

VAR2:8,COLORGREEN,LINETHICK0;

上升在即: IF(CROSS(VAR1,VAR2),80,0),STICK,COLOR0000CC,LINETHICK2;

专吸庄血: IF(VAR1<=8,25,0),STICK,COLORWHITE,LINETHICK2;


信号很多,就做一个“红柱子”的选股吧,如果有其他选股公式需要的,扫描右上角二维码联系我。

选股公式如下 :

N:=5;

VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-

3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1);

CROSS(VAR1,8);


测试一下,平仓规则是,不论盈亏,以持股5天后平仓为条件

QQ截图20211025085814.png

胜率47.78%


下一篇《通达信“高低位决策主图”指标公式和选股公式——指标分享,胜率49.20%


打赏
« 上一篇 下一篇 »

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。