27
2021
07

通达信“大胆博主图”指标公式和选股公式——指标分享​,胜率46.84%

QQ截图20210723090454.png

上一篇《通达信“黑马恐怖”指标公式和选股公式——指标分享,胜率46.90%


公式如下 :

N:=13;

M1:=20;

M2:=20;

MID:((1+M1/100)*MA(CLOSE,N)+(1-M2/100)*MA(CLOSE,N))/2;

RSV:=((HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13)))*(100);

LWR1:=SMA(RSV,3,1);

LWR2:=SMA(LWR1,5,1);

STICKLINE((LWR1>=LWR2),HIGH,LOW,0.05,0),COLORFFDDC0;

STICKLINE((LWR1>=LWR2),OPEN,CLOSE,5,0),COLORFFDDC0;

STICKLINE((LWR1<LWR2),HIGH,LOW,0.05,0),COLOR0000FF;

STICKLINE((LWR1<LWR2),OPEN,CLOSE,5,1),COLOR0000FF;

VAR1AA:=((2)*(CLOSE)+OPEN+HIGH+LOW)/(5);

VAR2AA:=VOL;

上升:(SUM((VAR1AA)*(VAR2AA),8))/(SUM(VAR2AA,8)),COLORRED;

下降:LLV(上升,8),COLOR00FF00;

DRAWTEXT_FIX(C>O,0.01,0.9,0,'微信公众号:水鸭的投资日记'),COLORRED;

VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);

DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.94999998),'大胆搏 '),COLOR00FFFF;

DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★'),COLOR00FFFF;

A1AA:=9;

A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);

DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心'),COLORFFFFFF;

VAR1:=REF(CLOSE,1);

VAR2:=MA(CLOSE,5);

VAR3:=SMA(MAX(CLOSE-VAR1,0),6,1)/SMA(ABS(CLOSE-VAR1),6,1)*100;

VAR4:=SMA(MAX(CLOSE-VAR1,0),12,1)/SMA(ABS(CLOSE-VAR1),12,1)*100;

VAR5:=SMA(MAX(CLOSE-VAR1,0),24,1)/SMA(ABS(CLOSE-VAR1),24,1)*100;

VAR6:=IF(CROSS(VAR3,VAR5),LOW,REF(LOW,BARSLAST(CROSS(VAR3,VAR5))));

VAR7:=IF(CROSS(VAR5,VAR3),HIGH,REF(HIGH,BARSLAST(CROSS(VAR5,VAR3))));

VAR8:=IF(CLOSE>=MA(CLOSE,20),80,50);

VAR9:=IF(CLOSE>=MA(CLOSE,20),50,20);

VARA:=IF(VAR3<VAR8 AND REF(VAR3,1)>=VAR8,HHV(REF(HIGH,1),BARSLAST(VAR3>=VAR8 AND REF(VAR3,1)<VAR8)-1),REF(HHV(REF(HIGH,1),BARSLAST(VAR3>=VAR8 AND REF(VAR3,1)<VAR8)-1),BARSLAST(VAR3<VAR8 AND REF(VAR3,1))));

VARB:=IF(HIGH>VARA,LOW,REF(LOW,BARSLAST(HIGH>VARA)));

VARC:=IF(HIGH>VARA,VAR3,REF(VAR3,BARSLAST(HIGH>VARA)));

VARD:=IF(HIGH>VARB AND VAR3<VARC AND VAR3<VAR5,HIGH,REF(HIGH,BARSLAST(HIGH>VARB AND VAR3<VARC AND VAR3<VAR5)));

VARE:=IF(VAR3>VAR9 AND REF(VAR3,1)<=VAR9,LLV(REF(LOW,1),BARSLAST(VAR3<=VAR9 AND REF(VAR3,1)>VAR9)-1),REF(LLV(REF(LOW,1),BARSLAST(VAR3<=VAR9 AND REF(VAR3,1)>VAR9)-1),BARSLAST(VAR3>VAR9 AND REF(VAR3,1))));

VARF:=IF(LOW<VARE,HIGH,REF(HIGH,BARSLAST(LOW<VARE)));

VAR10:=IF(LOW<VARE,VAR3,REF(VAR3,BARSLAST(LOW<VARE)));

VAR11:=IF(LOW<VARF AND VAR3>VAR10 AND VAR3>VAR5,LOW,REF(LOW,BARSLAST(LOW<VARF AND VAR3>VAR10 AND VAR3>VAR5)));


信号很多,就做一个“大胆博”的选股吧,如果有其他选股公式需要的,扫描右上角二维码联系我。

选股公式如下 :

AB:=IF((CLOSE>REF(CLOSE,1)),88,0);

AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (AB>0),91,0);

FILTER((AA>90),45);


测试一下,平仓规则是,不论盈亏,以持股5天后平仓为条件

QQ截图20210723090908.png

胜率46.84%


下一篇《通达信“扬起风帆”指标公式和选股公式——指标分享,胜率52.04%




打赏
« 上一篇 下一篇 »

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。