30
2017
03

修改一个MACD日周月金的选股公式

上一篇《长下影线的选股公式


QQ截图20170330131042_副本.png

读者的公式如下

MK:=MACD.DIF#MONTH; MD:=MACD.DEA#MONTH; WK:=MACD.DIF#WEEK; WD:=MACD.DEA#WEEK; DK:=MACD.DIF; DD:=MACD.DEA; XG:((DK>DD AND WK>WD AND CORSS(MK,MD)) OR (WK>WD AND MK>MD AND CROSS(DK,DD)) OR (MK>MD AND DK>DD AND CROSS(WK,WD)) OR (CROSS(MK,MD) AND CROSS(DK,DD) AND CROSS(WK,WD)));


把它输入指标公式编辑器中

1.png

有一个错误句,观察错误句,有一个单词拼错了,CORSS,应该是CROSS


2.png


通过了,试试

3.png

搞掂。


修改后的公式如下

MK:=MACD.DIF#MONTH; 

MD:=MACD.DEA#MONTH; 

WK:=MACD.DIF#WEEK; 

WD:=MACD.DEA#WEEK; 

DK:=MACD.DIF; 

DD:=MACD.DEA; 

XG:((DK>DD AND WK>WD AND CROSS(MK,MD)) OR (WK>WD AND MK>MD AND CROSS(DK,DD)) OR (MK>MD AND DK>DD AND CROSS(WK,WD)) OR (CROSS(MK,MD) AND CROSS(DK,DD) AND CROSS(WK,WD)));


下一篇《均线多头排列——和读者的互相学习印证




打赏
« 上一篇 下一篇 »

发表评论:

◎欢迎参与讨论,请在这里发表您的看法、交流您的观点。